Installation Process

  1. Requirements
  2. Validate Purchase Code
  3. Database Installation
  4. Admin Account
  5. Installation Complete

Home | Products | Support

2012-2022 © GemPixel
All Rights Reserved.

Premium URL Shortener

Premium URL Shortener Requirements

PHP Version (v7.4+) You have 7.4.30

It is very important to have at least PHP Version 7.4. It is highly recommended that you use 7.4 or later for best performance.

Filesystem

  • config_sample.php must be accessible Accessible

    This installation will open that file to put values in so it must be accessible. Make sure that file is there in the root folder and is writable.

  • storage/ folder and its subfolder must be writable. Accessible

    Many things will be uploaded to that folder so please make sure it has the proper permission.

  • public/content/ folder must be writable. Accessible

    Mbstring is required for correct encoding.

Modules & Extensions

  • PDO/MYSQL DriverEnabled

    PDO driver is very important so it must enabled. Without this, the script will not connect to the database hence it will not work at all. If this verify fails, you will need to contact your web host and ask them to either enable it or configure it properly.

  • cURL Enabled

    cURL is used to interact with external servers and APIs.

  • Mbstring Enabled

    Mbstring is required for correct encoding.

  • GD Library Enabled

    GD library is needed to generate QRs.

  • ImageMagick Enabled

    ImageMagick library is not required and you can proceed with installation. This extension is needed for advanced QRs. You can still generate QR codes without this extension but if you want to have advanced styling, this is needed. We recommend Imagick version 7.1.

Proceed